Mobile GMaps Home Page
 FAQFAQ    SearchSearch    MemberlistMemberlist    UsergroupsUsergroups   RegisterRegister  
 ProfileProfile    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Requests to re-sign MGMaps

 
Post new topic   Reply to topic   printer-friendly view    MGMaps Forum Index -> Miscellaneous
View previous topic :: View next topic  
Author Message
Cristian Streng
Founder


Joined: 28 Oct 2005
Posts: 4585

Phone Type: (many)

PostPosted: Sun Aug 03, 2008 2:40 pm    Post subject: Requests to re-sign MGMaps Reply with quote

The certificate used to sign MGMaps expires on August 21, 2008. All versions signed with this certificate will continue to work if installed before that date, after that you will not be able to install them. Please post here any requests to re-sign specific versions of MGMaps with the new certificate, I'll sign them and upload the new jad file to the server as soon as possible. Include version number and platform (only generic and Nokia N95 branches need to be re-signed).
Back to top
View user's profile Send private message Visit poster's website
FelixII
Junior


Joined: 29 Jul 2008
Posts: 5

Phone Type: Unknown

PostPosted: Sat Aug 23, 2008 1:18 pm    Post subject: Reply with quote

Hi Christian,

I tried to upgrade from 1.41.02 to 1.41.03 today (23.08.08 ) and I'm getting this error message: "An error occured verifying the provider certificate for Mobile GMaps - 11 Plese contact the application provider for more information."

Please upload the fixed 1.41.03 jad file (platform: generic). Thank you!
Back to top
View user's profile Send private message
Cristian Streng
Founder


Joined: 28 Oct 2005
Posts: 4585

Phone Type: (many)

PostPosted: Sat Aug 23, 2008 5:29 pm    Post subject: Reply with quote

FelixII wrote:
Hi Christian,

I tried to upgrade from 1.41.02 to 1.41.03 today (23.08.08 ) and I'm getting this error message: "An error occured verifying the provider certificate for Mobile GMaps - 11 Plese contact the application provider for more information."

Please upload the fixed 1.41.03 jad file (platform: generic). Thank you!

Well... it's already on the server! Versions 1.39.16 and 1.41.03 are signed with the new certificate. What phone do you have?
Back to top
View user's profile Send private message Visit poster's website
FelixII
Junior


Joined: 29 Jul 2008
Posts: 5

Phone Type: Unknown

PostPosted: Sun Aug 24, 2008 12:09 pm    Post subject: Reply with quote

I tried a bit more and got it to work by downloading the single files from your server, the files from the zip archive didn't work for me. I have a HTC Artemis smartphone with Windows Mobile 6 and use the JBed - java emulator.
Back to top
View user's profile Send private message
Cristian Streng
Founder


Joined: 28 Oct 2005
Posts: 4585

Phone Type: (many)

PostPosted: Sun Aug 24, 2008 3:17 pm    Post subject: Reply with quote

FelixII wrote:
I tried a bit more and got it to work by downloading the single files from your server, the files from the zip archive didn't work for me. I have a HTC Artemis smartphone with Windows Mobile 6 and use the JBed - java emulator.

Ah, you're right, the zip files were not up-to-date. Fixed now.
Back to top
View user's profile Send private message Visit poster's website
cliffdbrown
Newbie


Joined: 25 Aug 2008
Posts: 1

Phone Type: Unknown

PostPosted: Mon Aug 25, 2008 2:32 pm    Post subject: GMaps stopped working...certificate issue? Reply with quote

I installed GMaps on an Moto ic502 last week and it worked great. It stopped working however (it won't get a fix) in the last couple of days.

I know the conventional wisdom is that the security certificate only comes into play during installation, but it is possible that on this phone an expired certificate would cause the the locator API to stop working?

Incidentally, the lastest version of the sprint SDK includes a certificate so you don't need to purchase your own.

I'd be interested to know if anyone else has experienced this loss of functionality since the certificate experation date.
Back to top
View user's profile Send private message
Cristian Streng
Founder


Joined: 28 Oct 2005
Posts: 4585

Phone Type: (many)

PostPosted: Mon Aug 25, 2008 5:59 pm    Post subject: Re: GMaps stopped working...certificate issue? Reply with quote

cliffdbrown wrote:
I know the conventional wisdom is that the security certificate only comes into play during installation, but it is possible that on this phone an expired certificate would cause the the locator API to stop working?

Theoretically yes, but if you have the Sprint version it is anyway signed with a Sprint developer certificate, not with the MGMaps Verisign certificate. And if you have the generic version of mgmaps, you can re-install/upgrade the to the latest one, it is signed with the new certificate.
Back to top
View user's profile Send private message Visit poster's website
JB101
Junior


Joined: 28 Oct 2008
Posts: 3

Phone Type: Unknown

PostPosted: Wed Oct 29, 2008 4:56 pm    Post subject: Samsung i8510 Reply with quote

Hi there,

I've been struggling for a while now.. just downloaded the most recent release - the signed version

Yet the damn phone (samsung i8510) still refuses to open the mgm files without me saying "yes allow this application" looking through the list of certificates on the phone the softcris srl isn't listed.

Am I doing something wrong here?

I can can run the app but everytime I move the map I have to hit yes 3 or so times to allow the new mgm files to load.
Back to top
View user's profile Send private message
Cristian Streng
Founder


Joined: 28 Oct 2005
Posts: 4585

Phone Type: (many)

PostPosted: Wed Oct 29, 2008 5:37 pm    Post subject: Re: Samsung i8510 Reply with quote

JB101 wrote:
Hi there,

I've been struggling for a while now.. just downloaded the most recent release - the signed version

Yet the damn phone (samsung i8510) still refuses to open the mgm files without me saying "yes allow this application" looking through the list of certificates on the phone the softcris srl isn't listed.

Am I doing something wrong here?

I can can run the app but everytime I move the map I have to hit yes 3 or so times to allow the new mgm files to load.

The "list of certificates" lists only root authorities, MGMaps needs Verisign Class 3 for signing java applications. (there's another Verisign Class 3 certificate for SSL websites).

The phone seems to be based on Symbian S60 3rd edition FP2, like recent Nokia phones (N96, N85, N78). Have you configured application permissions? In the phone app manager select "Mobile GMaps", then "Open", scroll to "Read User Data", set to "Always Allow".
Back to top
View user's profile Send private message Visit poster's website
mohdjai
Newbie


Joined: 18 Dec 2008
Posts: 1

Phone Type: Unknown

PostPosted: Thu Dec 18, 2008 7:23 am    Post subject: Motorola A780 Reply with quote

Request Motorola A780 release v1.39.13 new certificate,
My phone is motorola v3xx

Thank you so much!
Back to top
View user's profile Send private message
Cristian Streng
Founder


Joined: 28 Oct 2005
Posts: 4585

Phone Type: (many)

PostPosted: Wed Dec 31, 2008 8:08 am    Post subject: Re: Motorola A780 Reply with quote

mohdjai wrote:
Request Motorola A780 release v1.39.13 new certificate,
My phone is motorola v3xx

Thank you so much!

I have uploaded a new A780 version (1.39.17, signed), see if it works.
Back to top
View user's profile Send private message Visit poster's website
apienk01
Newbie


Joined: 13 Feb 2009
Posts: 1
Location: Poland
Phone Type: Motorola V3xx

PostPosted: Fri Feb 13, 2009 1:50 pm    Post subject: Reply with quote

I also have v3xx and unsuccesfully tried to install signed MGMaps. What certificate is MGMaps signed with? Isn't the A780 version signed with Motorola developer certificate?
Back to top
View user's profile Send private message
Cristian Streng
Founder


Joined: 28 Oct 2005
Posts: 4585

Phone Type: (many)

PostPosted: Tue Feb 17, 2009 9:09 am    Post subject: Reply with quote

apienk01 wrote:
I also have v3xx and unsuccesfully tried to install signed MGMaps. What certificate is MGMaps signed with? Isn't the A780 version signed with Motorola developer certificate?

No, it's signed with the same Verisign certificate that I use for signing the generic version.
Back to top
View user's profile Send private message Visit poster's website
Cristian Streng
Founder


Joined: 28 Oct 2005
Posts: 4585

Phone Type: (many)

PostPosted: Tue Aug 25, 2009 6:59 am    Post subject: Reply with quote

up

Old certificate expired on August 21, 2009, latest versions 1.39.21 and 1.42.01 are signed with the new certificate, post any requests to re-sign older versions below.
Back to top
View user's profile Send private message Visit poster's website
jiminyc
Junior


Joined: 06 Dec 2009
Posts: 3

Phone Type: SPH-M560

PostPosted: Sun Dec 06, 2009 8:24 am    Post subject: Reply with quote

[quote]... (only generic and Nokia N95 branches need to be re-signed)./quote]

Hmmm...

I am getting "910 Application Authorization Failure" trying to download 1.39.20 for Sprint GPS (for Samsung SPH-M560). Please sign version 1.39.21 for Sprint GPS if you think that would solve the problem, despite the quote above. Thank you.
Back to top
View user's profile Send private message
Cristian Streng
Founder


Joined: 28 Oct 2005
Posts: 4585

Phone Type: (many)

PostPosted: Sun Dec 06, 2009 10:12 am    Post subject: Reply with quote

[quote="jiminyc"]
Quote:
... (only generic and Nokia N95 branches need to be re-signed)./quote]

Hmmm...

I am getting "910 Application Authorization Failure" trying to download 1.39.20 for Sprint GPS (for Samsung SPH-M560). Please sign version 1.39.21 for Sprint GPS if you think that would solve the problem, despite the quote above. Thank you.

This was fixed yesterday, please try again.
Back to top
View user's profile Send private message Visit poster's website
jiminyc
Junior


Joined: 06 Dec 2009
Posts: 3

Phone Type: SPH-M560

PostPosted: Sun Dec 06, 2009 9:01 pm    Post subject: Reply with quote

I just tried it again minutes ago-- file...

http://wap.mgmaps.com/13/mgmaps_sprint-1_39_20.jad

...over-the-air, and still get the same error, "910 Application Authorization Failure". (I do have the phone's CERT setting = "ON". With CERT set to OFF, I get "909 Application Authorization Error".)

Note: I am able to install and run the signed, Generic file...
http://wap.mgmaps.com/13/mgmaps-1_39_21-signed.jad
...and after allowing all application permissions, find that "Settings | GPS | Select Device" is set to "Internal". Waiting under open sky for many minutes, I still get no position info. Unfortunately, after going through all the various displays and check boxes, I can't even discriminate whether the app is actually reading binary or ASCII NMEA strings or whether it isn't able to access the phone's GPS subsystem at all(!).

Questions:
1. Has the ...sprint-1_39_20.jad file above been signed recently?
2. Why is there no version 1.39.21 for Sprint GPS?
3. Is there a way to determine positively that the MGMaps app is getting and parsing "NMEA" strings or binary GPS data from the phone?

Thanks for all your work on this great application!
Back to top
View user's profile Send private message
xvs
Junior


Joined: 05 Dec 2009
Posts: 3

Phone Type: Unknown

PostPosted: Wed Dec 09, 2009 3:12 am    Post subject: Reply with quote

[quote="Cristian Streng"]
jiminyc wrote:
Quote:
1.39.21 for Sprint GPS if you think that would solve the problem, despite the quote above. Thank you.

This was fixed yesterday, please try again.


Hi Cristian,

Thanks for signing 1.39.20. It works for me.

Question: how about 1.39.21?

Thanks!
X
Back to top
View user's profile Send private message
cyberbiker
MGMapper


Joined: 18 May 2007
Posts: 20

Phone Type: Unknown

PostPosted: Fri Dec 18, 2009 3:55 pm    Post subject: Reply with quote

I just had to replace my Sanyo 8400 (Sprint) with one that had not previoulsy had Mgmaps installed and activated it at http://developer.sprint.com . However, every time I try to install Sprint Signed.jad v1.39.20, it gives me error 909 "Application Authorization Failure".

I then went to the previous versions webpage at http://wap.mgmaps.com/13/index-all.html and found I got the same error with earlier Sprint versions. More specifics at http://forum.mgmaps.com/viewtopic.php?t=3200 .

1) Is everyone getting the Application Authorization Failure a Sprint customer?
2) Has anyone installed Sprint signed.jad v1.39.20 successfully?

_________________
Sprint - Sanyo 8400 & Novatel EX720
Back to top
View user's profile Send private message
Jo The Trekker
Junior


Joined: 22 Mar 2011
Posts: 3

Phone Type: Unknown

PostPosted: Wed Mar 23, 2011 4:37 pm    Post subject: Reply with quote

cyberbiker wrote:
I just had to replace my Sanyo 8400 (Sprint) with one that had not previoulsy had Mgmaps installed and activated it at http://developer.sprint.com . However, every time I try to install Sprint Signed.jad v1.39.20, it gives me error 909 "Application Authorization Failure".

I then went to the previous versions webpage at http://wap.mgmaps.com/13/index-all.html and found I got the same error with earlier Sprint versions. More specifics at http://forum.mgmaps.com/viewtopic.php?t=3200 .

1) Is everyone getting the Application Authorization Failure a Sprint customer?
2) Has anyone installed Sprint signed.jad v1.39.20 successfully?


I can answer your first question very easily. The Application Authorization issue plagued Sprint phones for a while, but since seems to have been fixed although I cannot guarantee this because I am an AT&T customer. Everything seems to work just fine with new and refurbished cell phones, a place that sells those is http://www.thebluedot.net/. This is based off of other topics I have seen in the forums and personal experience.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic   printer-friendly view    MGMaps Forum Index -> Miscellaneous All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
MGMaps topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group