Mobile GMaps Home Page
 FAQFAQ    SearchSearch    MemberlistMemberlist    UsergroupsUsergroups   RegisterRegister  
 ProfileProfile    Log in to check your private messagesLog in to check your private messages    Log inLog in 

Problem with Motorola A780
Goto page Previous  1, 2, 3
 
Post new topic   Reply to topic   printer-friendly view    MGMaps Forum Index -> Usage Questions and Problems
View previous topic :: View next topic  
Author Message
pnail
MGMapper


Joined: 21 Oct 2007
Posts: 18
Location: Bangalore, India
Phone Type: Moto A780

PostPosted: Fri Feb 01, 2008 7:29 pm    Post subject: Reply with quote

well, finally got my BT GPS, not able to connect still.

Am using bluez - my devices are paired and I can see the NMEA messages on /dev/rfcomm0.

But on mgmaps, am unable to select bluetooth as GPS device (Bluetooth not supported on this device error). Here are the contents of the debug logs:

ERROR: EX: java.lang.illegalArgumentException
DESC: Error connecting to GPS
MSG: Invalid port number

Even tried configuring serial port (/dev/rfcomm0) as GPS device, that didn't help either (probably above error is for serial port settings)

Would appreciate any tips on what am doing wrong...

pnail.
________
Hondamatic history


Last edited by pnail on Wed Feb 02, 2011 7:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
Cristian Streng
Founder


Joined: 28 Oct 2005
Posts: 4585

Phone Type: (many)

PostPosted: Sat Feb 02, 2008 6:59 am    Post subject: Reply with quote

pnail wrote:
well, finally got my BT GPS, not able to connect still.

Am using bluez - my devices are paired and I can see the NMEA messages on /dev/rfcomm0.

But on mgmaps, am unable to select bluetooth as GPS device (Bluetooth not supported on this device error). Here are the contents of the debug logs:

ERROR: EX: java.lang.illegalArgumentException
DESC: Error connecting to GPS
MSG: Invalid port number

Even tried configuring serial port (/dev/rfcomm0) as GPS device, that didn't help either (probably above error is for serial port settings)

Would appreciate any tips on what am doing wrong...

pnail.

Try "rfcomm0" or "rfcomm" for the serial port name... I'm packing jsr82 in the jar too, maybe your phone doesn't have permission to access it? That error above is for serial, does it show any error for bluetooth? Try help -> report problem so I can see the parameters detected (incl. bluetooth)
Back to top
View user's profile Send private message Visit poster's website
pnail
MGMapper


Joined: 21 Oct 2007
Posts: 18
Location: Bangalore, India
Phone Type: Moto A780

PostPosted: Sat Feb 02, 2008 7:30 am    Post subject: Reply with quote

I've sent 2 reports, 1st with gps using serial device as rfcomm0 and 2nd when bluetooth is selected as gps device.

meanwhile let me check the permission part...
________
Hurricane


Last edited by pnail on Wed Feb 02, 2011 7:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
jeanlee411
Newbie


Joined: 01 May 2010
Posts: 1

Phone Type: Unknown

PostPosted: Sat May 01, 2010 2:56 am    Post subject: Reply with quote

yep, works fine in online mode (through bluezx in my case). I don't have a (internal/external) GPS (yet!) to verify if GPS is working - anyone else with GPS please report your findings here.

I cannot still get offline mode to work - neither is browse button visible. When stored option is enabled, message "Filesystem storage is not supported on this phone" is displayed. I've tried replacing permfile.txt and followed method as per A1200 thread - but still not able to enable file access. A780 j2me experts please help!!

Many thanks to Cristian for his help and patience Wink

_________________
Watch Furry Vengeance Online Free
Back to top
View user's profile Send private message
harper36
Junior


Joined: 06 Dec 2010
Posts: 3

Phone Type: Unknown

PostPosted: Mon Dec 06, 2010 2:39 pm    Post subject: Reply with quote

still same results with Smile "Storage directory does not exist" error. Also additional "javax.microedition.rms.Invalid RecordIDException, Smile DESC: Error loading record #13" & #12 errors are appearing. This version too is able to access kml file. Smile

Browsing for file is adding extra folder as before - except some '/' (slashes) are reduced now in the top status bar [/SD//SD/MGMapsCache]. Smile

Tried reporting problem online (directly from the phone) with the logs Smile - but thats doesn't seem to be working. Smile
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic   printer-friendly view    MGMaps Forum Index -> Usage Questions and Problems All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
MGMaps topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group