Problem with Motorola A780
Select messages from
# through # FAQ
[/[Print]\]
Goto page 1, 2, 3  Next  :| |:
MGMaps -> Usage Questions and Problems

#1: Problem with Motorola A780 Author: shankiearora PostPosted: Mon Aug 06, 2007 5:13 am
    —
Hey friends I am using Motorola A780 & NOP ( wap service) with Airtel in India. I'm unable to use Mgmaps in my phone. Plz help.

or plz mail me at: shankiearora@gmail.com

#2: Re: Problem with Motorola A780 Author: Cristian Streng PostPosted: Mon Aug 06, 2007 5:26 am
    —
shankiearora wrote:
Hey friends I am using Motorola A780 & NOP ( wap service) with Airtel in India. I'm unable to use Mgmaps in my phone. Plz help.

or plz mail me at: shankiearora@gmail.com

See other threads about this... for example http://forum.mgmaps.com/viewtopic.php?t=885&highlight=a780. Try to install MGMaps v1.35.02 for Motorola A780, that should work just fine. Anyway, you should make sure you have internet access on your phone, WAP may not be enough to allow you to view the maps.

Cristian

#3: Re: Problem with Motorola A780 Author: pnailLocation: Bangalore, India PostPosted: Tue Oct 23, 2007 4:53 pm
    —
Why is it that only 1_35_02 version works on my A780 (no internal GPS - asian version) and all other later versions for A780 (upto latest 1_38_00) give "java.lang.NoClassDefFoundError: com/sprintpcs/util/Location" or "java.lang.NoClassDefFoundError: Location" error (please refer attached log file)?

For stored maps, which version browse button got added? Am unable to get offline mode to work - I guess need to figure out howto enable file access for the app and also be sure my path setting (TransFlash/MGMapsCache) is correct. Anyone here got offline mode working on A780?
________
Jalpa


Last edited by pnail on Wed Feb 02, 2011 7:41 pm; edited 1 time in total


log.txt
 Description:
A780 JVM log (v1_38_00)

Download
 Filename:  log.txt
 Filesize:  5.62 KB
 Downloaded:  866 Time(s)


#4: Re: Problem with Motorola A780 Author: Cristian Streng PostPosted: Tue Oct 23, 2007 5:44 pm
    —
pnail wrote:
Why is it that only 1_35_02 version works on my A780 (no internal GPS - asian version) and all other later versions for A780 (upto latest 1_38_00) give "java.lang.NoClassDefFoundError: com/sprintpcs/util/Location" or "java.lang.NoClassDefFoundError: Location" error (please refer attached log file)?

Ah... so that's the reason why it doesn't work! Thanks for letting me know about the exception that you get. Will be fixed in the next version for A780.

#5:  Author: Cristian Streng PostPosted: Wed Oct 24, 2007 6:52 am
    —
Please try the version attached and let me know if it fixes the problem.

Regards,
Cristian


Last edited by Cristian Streng on Fri Jan 25, 2008 12:07 pm; edited 1 time in total

#6:  Author: pnailLocation: Bangalore, India PostPosted: Wed Oct 24, 2007 4:48 pm
    —
Getting "java.lang.NoClassDefFoundError: javax/microedition/io/file/FileConnection" this time (details in attached log file)
________
vaporite solo


Last edited by pnail on Wed Feb 02, 2011 7:41 pm; edited 1 time in total


log_a780_1_38_02-alpha.txt
 Description:

Download
 Filename:  log_a780_1_38_02-alpha.txt
 Filesize:  5.73 KB
 Downloaded:  797 Time(s)


#7:  Author: Cristian Streng PostPosted: Wed Oct 24, 2007 5:51 pm
    —
pnail wrote:
Getting "java.lang.NoClassDefFoundError: javax/microedition/io/file/FileConnection" this time (details in attached log file)

Try this new version attached and let me know what you get.

Cristian


Last edited by Cristian Streng on Fri Jan 25, 2008 12:06 pm; edited 1 time in total

#8:  Author: pnailLocation: Bangalore, India PostPosted: Thu Oct 25, 2007 2:16 pm
    —
yep, works fine in online mode (through bluezx in my case). I don't have a (internal/external) GPS (yet!) to verify if GPS is working - anyone else with GPS please report your findings here.

I cannot still get offline mode to work - neither is browse button visible. When stored option is enabled, message "Filesystem storage is not supported on this phone" is displayed. I've tried replacing permfile.txt and followed method as per A1200 thread - but still not able to enable file access. A780 j2me experts please help!!

Many thanks to Cristian for his help and patience Wink
________
Ducati 999


Last edited by pnail on Wed Feb 02, 2011 7:42 pm; edited 1 time in total

#9:  Author: Cristian Streng PostPosted: Thu Oct 25, 2007 2:18 pm
    —
pnail wrote:
yep, works fine in online mode (through bluezx in my case). I don't have a (internal/external) GPS (yet!) to verify if GPS is working - anyone else with GPS please report your findings here.

I cannot still get offline mode to work - neither is browse button visible. When stored option is enabled, message "Filesystem storage is not supported on this phone" is displayed. I've tried replacing permfile.txt and followed method as per A1200 thread - but still not able to enable file access. A780 j2me experts please help!!

Many thanks to Cristian for his help and patience Wink

As far as I know, A780 does not have support for JSR-75. Instead it uses a different API (Motorola file system API), not supported in MGMaps yet.

Cristian

#10:  Author: pnailLocation: Bangalore, India PostPosted: Fri Jan 25, 2008 6:32 am
    —
Cristian,

Please check your pm for update on Moto file API. Do let us know if its possible to get offline mode working now on A780 - I can test the app now that I got external GPS unit with me!! Please post the alpha version here.

Thanks again for the great app...

-pnail
________
Cooking Help


Last edited by pnail on Wed Feb 02, 2011 7:42 pm; edited 1 time in total

#11:  Author: Cristian Streng PostPosted: Fri Jan 25, 2008 6:40 am
    —
pnail wrote:
Cristian,

Please check your pm for update on Moto file API. Do let us know if its possible to get offline mode working now on A780 - I can test the app now that I got external GPS unit with me!! Please post the alpha version here.

Thanks again for the great app...

-pnail

I did check it, but I don't have the com.motorola.io libraries, I'll need to find them somewhere... I wonder what wtk they come with.

#12:  Author: Cristian Streng PostPosted: Fri Jan 25, 2008 7:13 am
    —
OK, found this: http://www.motorolafans.com/forums/archive/index.php/t-1570.html, it seems they took that API out from recent SDKs, I'm getting an old one, and hopefully I'll have a version ready in a few hours.

#13:  Author: Cristian Streng PostPosted: Fri Jan 25, 2008 7:56 am
    —
Try this version attached... (may not be able to use the GPS but the filesystem should work)

Last edited by Cristian Streng on Mon Jan 28, 2008 7:31 am; edited 1 time in total

#14:  Author: whonsir PostPosted: Fri Jan 25, 2008 12:36 pm
    —
Cristian Streng wrote:
Try this version attached... (may not be able to use the GPS but the filesystem should work)


it can't be installed on moto e6.(Invalid document)

#15:  Author: Cristian Streng PostPosted: Fri Jan 25, 2008 12:39 pm
    —
whonsir wrote:
it can't be installed on moto e6.(Invalid document)

This is the signed version... did you have the unsigned version earlier installed? Or maybe you didn't have any previous version installed, but your phone doesn't have the signatures - try to install directly from the jar.

#16:  Author: whonsir PostPosted: Fri Jan 25, 2008 1:26 pm
    —
Cristian Streng wrote:
whonsir wrote:
it can't be installed on moto e6.(Invalid document)

This is the signed version... did you have the unsigned version earlier installed? Or maybe you didn't have any previous version installed, but your phone doesn't have the signatures - try to install directly from the jar.

ok Smile

#17:  Author: Cristian Streng PostPosted: Fri Jan 25, 2008 1:58 pm
    —
I made some updates (and corrected some bugs), try this new version I'm attaching. It's signed, but if you get errors installing let me know and I'll send the unsigned version.

Last edited by Cristian Streng on Mon Jan 28, 2008 7:31 am; edited 1 time in total

#18:  Author: whonsir PostPosted: Sun Jan 27, 2008 10:10 am
    —
Cristian Streng wrote:
I made some updates (and corrected some bugs), try this new version I'm attaching. It's signed, but if you get errors installing let me know and I'll send the unsigned version.


I installed this version successfully from the jar.but there is still no "menu" soft key on my screen,and I pressed all the keys one by one on my phone,the "menu" soft key couldn't be found...

#19:  Author: whonsir PostPosted: Sun Jan 27, 2008 10:15 am
    —
by the way,when I click the jad and try to run it on Windows XP(with WTK),it shows:

com.sun.kvem.midletsuite.InvalidJadException: Reason = 36
Error in opening jar file: mgmaps.jar

#20:  Author: Cristian Streng PostPosted: Sun Jan 27, 2008 11:39 am
    —
whonsir wrote:
Cristian Streng wrote:
I made some updates (and corrected some bugs), try this new version I'm attaching. It's signed, but if you get errors installing let me know and I'll send the unsigned version.


I installed this version successfully from the jar.but there is still no "menu" soft key on my screen,and I pressed all the keys one by one on my phone,the "menu" soft key couldn't be found...

Sorry, but I've got no clue yet. See the other threads from Motorola users on this forum, maybe they can help you.

whonsir wrote:
by the way,when I click the jad and try to run it on Windows XP(with WTK),it shows:

com.sun.kvem.midletsuite.InvalidJadException: Reason = 36
Error in opening jar file: mgmaps.jar

You need to have both the jad and the jar files present.



MGMaps -> Usage Questions and Problems


output generated using printer-friendly topic mod. All times are GMT

Goto page 1, 2, 3  Next  :| |:
Page 1 of 3

Powered by phpBB © 2001, 2005 phpBB Group