Mobile GMaps Home Page
 FAQFAQ    SearchSearch    MemberlistMemberlist    UsergroupsUsergroups   RegisterRegister  
 ProfileProfile    Log in to check your private messagesLog in to check your private messages    Log inLog in 

[Fixed] Internal GPS not working on HTC/Windows-Mobile
Goto page Previous  1, 2, 3
 
Post new topic   Reply to topic   printer-friendly view    MGMaps Forum Index -> GPS Problems and Suggestions
View previous topic :: View next topic  
Author Message
Cristian Streng
Founder


Joined: 28 Oct 2005
Posts: 4585

Phone Type: (many)

PostPosted: Sat Oct 17, 2009 7:24 pm    Post subject: Reply with quote

Ryuuketsu wrote:
I'll post this in the correct section.

So, I finally was able to install mgmaps and open stored maps. All that is fine and dandy.

However, GPS is not working.

This is what I have installed on my ASUS P750 <with internal GPS> :

JBed3dMod_HeapSizeFix_12.02.2008.cab
mgmaps-1_42_01.jad
mgmaps-1_42_01.jar
Windows Mobile 6.1
GpsPortPPC.exe

Selected mgmaps-> GPS --> GPSGate

Here is what I do to start the app:

Start GpsPortSP.exe < Tried two different settings COM4 20175 and COM5 57600>
Start JBED
Launch mgmaps <able to see stored maps>
Menu --> GPS --> Where Am I? <Gives the following error : GPS Position not yet determined. Make sure the phone can recieve/determine GPS info and the satellite signal stregnth is good, wait for a few seconds then try again. >


I have two other apps on the phone (Destinator and Travelogue). Both these are able to get the GPS signal.

Please let me know if I'm doing something wrong.


~Ryuu

Only port 20175 would be relevant. Also, select the COM port that is correct for your phone (where the GPS is shown as connected in other apps or in the phone config). Other applications are not Java apps but native and they can use native code to connect directly to the GPS.

As for MGMaps, I noticed some error... after restarting look in Help/Debug Log, if it shows some security error connecting to GPS device, you'd have to select Settings/GPS/Select Device/Internal, save settings, then select again Settings/GPS/Select Device/GPSGate, and save settings again. That's how I get it to work on my Touch Diamond, at this time I don't have a fix for this problem.
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic   printer-friendly view    MGMaps Forum Index -> GPS Problems and Suggestions All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
MGMaps topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group